Office SharePoint Server 2007 on a single server install failed

I have had a situation happen on occasion where Office SharePoint Server 2007 on a single server (the basic install option) fails. The error can occur for a variety of reasons, needless to say the error log message maybe obscure (it was to me). So here is what it looks like when I was installing:

I installed Microsoft Office SharePoint Server 2007 as a “Basic” install. Then I kicked off the install …

Somewhere along the configuration wizard, the install would fail. I tried a couple more times after trying different things … nothing would work.

The log file had the following error:

06/26/2007 01:43:48 8 INF Creating connection string for config db SharePoint_Config_21cd986b-83ca-4908-a9f7-89871f6e458d server MOSSMACHINEOfficeServers
06/26/2007 01:43:48 8 INF Creating connection string for admin content db SharePoint_AdminContent_9752c1e5-fd30-4a9b-9dbb-e853e39bc837 server MOSSMACHINEOfficeServers
06/26/2007 01:43:48 8 INF Using NTLM for sql connection string
06/26/2007 01:43:48 8 INF Openning configdb so that I can join it at server MOSSMACHINEOfficeServers database SharePoint_Config_21cd986b-83ca-4908-a9f7-89871f6e458d in eval mode
06/26/2007 01:43:48 8 INF Now joining to farm at server MOSSMACHINEOfficeServers database SharePoint_Config_21cd986b-83ca-4908-a9f7-89871f6e458d
06/26/2007 01:43:48 8 ERR Task configdb has failed with an unknown exception
06/26/2007 01:43:48 8 ERR Exception: System.InvalidOperationException: Windows SharePoint Services configuration infrastructure is not initialized. You must wait until completion before joining another server to the farm.
at Microsoft.SharePoint.Administration.SPFarm.Join()
at Microsoft.SharePoint.PostSetupConfiguration.ConfigurationDatabaseTask.CreateOrConnectConfigDb()
at Microsoft.SharePoint.PostSetupConfiguration.ConfigurationDatabaseTask.Run()
at Microsoft.SharePoint.PostSetupConfiguration.TaskThread.ExecuteTask()

Somehow it just couldn’t connect to the configuration database. As I mentioned above, I tried all the things that made sense to me … to no avail. Fortunately I ran into this article on TechNet: Install Office SharePoint Server 2007 on a stand-alone computer

In it, I found the following line:

Note:
If you uninstall Office SharePoint Server 2007 and then later install Office SharePoint Server 2007 on the same computer, the Setup program could fail when creating the configuration database causing the entire installation process to fail. You can prevent this failure by either deleting all the existing Office SharePoint Server 2007 databases on the computer or by creating a new configuration database. You can create a new configuration database by running the following command:

psconfig -cmd configdb -create -database

 

Running that line solved my problem … if this solves your problem, remember to delete the configuration databases which were created from the failed attempts and aren’t being used.

Hope this helps someone. Good luck!